Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Ralph H Castain (rhc_at_[hidden])
Date: 2007-07-18 11:08:47


It works for me in both cases, provided I give the fully qualified host name
for your first example. In other words, these work:

pn1180961:~/openmpi/trunk rhc$ mpirun -n 1 -host localhost printenv | grep
LD
[pn1180961.lanl.gov:22021] [0.0] test of print_name
OLDPWD=/Users/rhc/openmpi
LD_LIBRARY_PATH=/Users/rhc/openmpi/lib:/Users/rhc/lib:/opt/local/lib:/usr/lo
cal/lib:

pn1180961:~/openmpi/trunk rhc$ mpirun -n 1 -host pn1180961.lanl.gov printenv
| grep LD
[pn1180961.lanl.gov:22012] [0.0] test of print_name
OLDPWD=/Users/rhc/openmpi
LD_LIBRARY_PATH=/Users/rhc/openmpi/lib:/Users/rhc/lib:/opt/local/lib:/usr/lo
cal/lib:

But this will lockup:

pn1180961:~/openmpi/trunk rhc$ mpirun -n 1 -host pn1180961 printenv | grep
LD

The reason is that the hostname in this last command doesn't match the
hostname I get when I query my interfaces, so mpirun thinks it must be a
remote host - and so we stick in ssh until that times out. Which could be
quick on your machine, but takes awhile for me.

Hope that helps
Ralph

On 7/18/07 7:45 AM, "Gleb Natapov" <glebn_at_[hidden]> wrote:

> On Wed, Jul 18, 2007 at 04:27:15PM +0300, Gleb Natapov wrote:
>> Hi,
>>
>> With current trunk LD_LIBRARY_PATH is not set for ranks that are
>> launched on the head node. This worked previously.
>>
> Same more info. I use rsh pls.
> elfit1# /home/glebn/openmpi/bin/mpirun -np 1 -H elfit1 env | grep
> LD_LIBRARY_PATH
> gives nothing.
>
> The strange thing that I just found is that this one works
> elfit1# /home/glebn/openmpi/bin/mpirun -np 1 -H localhost env | grep
> LD_LIBRARY_PATH
> LD_LIBRARY_PATH=/home/glebn/openmpi/lib
>
> --
> Gleb.
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel