Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Brian Barrett (bbarrett_at_[hidden])
Date: 2007-05-08 16:03:36


Hi all -

As was discussed on the telecon a couple of weeks ago, to try to
lower the maintenance cost of the build system, starting this
Saturday Autoconf 2.60 and Automake 1.10 will be required to
successfully run autogen.sh on the trunk. As I mentioned in a
previous e-mail, the required versions of the autotools will be:

                Autoconf Automake Libtool
v1.1 2.57-2.59 1.9.6 1.5.22
v1.2 2.57-new 1.9.6-new 1.5.22-new
trunk 2.60-new 1.10.0-new 1.5.22-new

This means that there's no set of autotools that will be able to
build all three versions of Open MPI, but since very few people
currently spend time on v1.1, this should not present a major problem.

Brian