Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Greg Watson (gwatson_at_[hidden])
Date: 2007-01-22 11:39:23


I tried adding '-mca btl ^sm -mca mpi_preconnect_all 1' to the mpirun
command line but it still fails with identical error messages.

I don't understand the issue with allocating nodes under bproc. Older
versions of OMPI have always just queried bproc for the nodes that
have permissions set so I can execute on them. I've never had to
allocate any nodes using a hostfile or any other mechanism. Are you
saying that this no longer works?

Greg

On Jan 22, 2007, at 8:45 AM, Ralph H Castain wrote:

> Actually, I just looked at my notes on bluesteel and see that it is an
> unscheduled system - i.e., no LSF to allocate the nodes. That's a
> problem
> with the current code.
>
> I assume you must be feeding it a hostfile or something?? How are you
> telling mpirun which nodes to use?
>
> Brian and I just talked about the more general bproc allocator
> question and
> I can commit a change later today to fix the situation for
> bluesteel. Until
> then, I fear that we may not run on that system, though you could
> give it a
> try anyway.
>
>
> On 1/22/07 8:14 AM, "Ralph H Castain" <rhc_at_[hidden]> wrote:
>
>> Oh yeah - Galen noted that you also have to do a preconnect, so
>> what you
>> need to add to your command line is:
>>
>> -mca btl ^sm -mca mpi_preconnect_all 1
>>
>> Ralph
>>
>>
>>
>> On 1/22/07 8:02 AM, "Greg Watson" <gwatson_at_[hidden]> wrote:
>>
>>>
>>> On Jan 19, 2007, at 4:39 PM, Li-Ta Lo wrote:
>>>
>>>> On Fri, 2007-01-19 at 14:42 -0700, Greg Watson wrote:
>>>>>
>>>>> The libraries required by the program are:
>>>>>
>>>>> $ ldd x
>>>>> librt.so.1 => /lib64/tls/librt.so.1 (0x00002aaaaabc1000)
>>>>> libbproc.so.4 => /usr/lib64/libbproc.so.4
>>>>> (0x00002aaaaacdb000)
>>>>> libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaaade2000)
>>>>> libnsl.so.1 => /lib64/libnsl.so.1 (0x00002aaaaaee5000)
>>>>> libutil.so.1 => /lib64/libutil.so.1 (0x00002aaaaaffc000)
>>>>> libm.so.6 => /lib64/tls/libm.so.6 (0x00002aaaab100000)
>>>>> libpthread.so.0 => /lib64/tls/libpthread.so.0
>>>>> (0x00002aaaab286000)
>>>>> libc.so.6 => /lib64/tls/libc.so.6 (0x00002aaaab39b000)
>>>>> /lib64/ld-linux-x86-64.so.2 (0x00002aaaaaaab000)
>>>>>
>>>>> These all appear to be available on the nodes.
>>>>>
>>>>
>>>> I tried a recent (today/yesterday?) svn trunk. It works but it is
>>>> very slow (I am using tcp now).
>>>>
>>>> Ollie
>>>
>>> Does that mean that 1.2 does not support bproc?
>>>
>>> Greg
>>> _______________________________________________
>>> devel mailing list
>>> devel_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>
>>
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel