Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Greg Watson (gwatson_at_[hidden])
Date: 2006-11-18 20:25:21


It would be of great help for the Eclipse Parallel Tools Platform if
this was working. We get lots of requests for PTP on Windows, but
lack of OMPI support has prevented this to date.

Regards,

Greg

On Nov 18, 2006, at 12:39 PM, George Bosilca wrote:

> I'm impressed that it work with cygwin out of the box. Last time I
> tried, I had to patch the libtool, do some manual modifications of
> the configure script (of course after altering some of the .m4
> files). It worked, I was able to run a simple ping-pong program, but
> it took me something like 4 hours to compile.
>
> I'm out of office for the next week. I can give a try to the whole
> cygwin/SFU once I get back.
>
> Thanks,
> george.
>
> On Nov 18, 2006, at 9:22 AM, Jeff Squyres wrote:
>
>> I don't know if we're tried cygwin for a long, long time... My gut
>> reaction is that it "should work" (the wrappers are pretty simple C),
>> but I don't have any cygwin resources to test / fix this. :-(
>>
>> George -- got any insight?
>>
>>
>> On Nov 16, 2006, at 4:44 PM, Ralph Castain wrote:
>>
>>> I'm not sure about running under cygwin at this stage - I have
>>> compiled the
>>> code base there before as you did, but never tried to run anything
>>> in that
>>> environment.
>>>
>>> However, I believe 1.2 will operate under Windows itself. Of
>>> course, that
>>> means using the Windows compilers...but if you have those, you
>>> should be
>>> able to run.
>>>
>>> I'll have to defer to my colleagues who wrote those wrapper
>>> compilers as to
>>> why cygwin might be taking offense. They are all at the
>>> Supercomputing Expo
>>> this week, so response may be a little delayed.
>>>
>>> Ralph
>>>
>>>
>>> On 11/16/06 1:54 PM, "Beth Tibbitts" <tibbitts_at_[hidden]> wrote:
>>>
>>>>
>>>> I'm trying to build OpenMPI on windows with cygwin, to at least be
>>>> able to
>>>> demo the Eclipse PTP(Parallel Tools Platform)
>>>> on my laptop.
>>>>
>>>> I configured OpenMPI version 1.2 (openmpi-1.2b1) with the following
>>>> command:
>>>> ./configure --with-devel-headers --enable-mca-no-build=timer-
>>>> windows
>>>>
>>>> then did make all and make install, which all seemed to finish ok
>>>> When i try to compile a small test mpi program I get a segfault
>>>>
>>>> $ mpicc mpitest.c
>>>> Signal:11 info.si_errno:0(No error) si_code:23()
>>>> Failing at addr:0x401a06
>>>> *** End of error message ***
>>>> 15 [main] mpicc 7036 _cygtls::handle_exceptions: Error while
>>>> dumping
>>>> state
>>>> (probably corrupted stack)
>>>> Segmentation fault (core dumped)
>>>>
>>>>
>>>> ...Beth
>>>>
>>>> Beth Tibbitts (859) 243-4981 (TL 545-4981)
>>>> High Productivity Tools / Parallel Tools http://eclipse.org/ptp
>>>> IBM T.J.Watson Research Center
>>>> Mailing Address: IBM Corp., 455 Park Place, Lexington, KY 40511
>>>>
>>>> _______________________________________________
>>>> devel mailing list
>>>> devel_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>>
>>>
>>> _______________________________________________
>>> devel mailing list
>>> devel_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>
>>
>> --
>> Jeff Squyres
>> Server Virtualization Business Unit
>> Cisco Systems
>>
>>
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel