Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Jeff Squyres \(jsquyres\) (jsquyres_at_[hidden])
Date: 2006-06-05 18:04:00


Excellent suggestion; thanks.

Done!

> -----Original Message-----
> From: devel-bounces_at_[hidden]
> [mailto:devel-bounces_at_[hidden]] On Behalf Of Josh Aune
> Sent: Monday, June 05, 2006 4:55 PM
> To: Open MPI Developers
> Subject: [OMPI devel] Please add explicit test for sysfs/libsysfs.h
>
> So far, every system I have compiled open-mpi on I have hit this same
> non-obvious configure failure. In each case I have added
> --with-openib=<path> and --with-openib-libs=<path>. configure runs
> just fine till it starts looking for OpenIB and reports that it can't
> find most of the header files and what not relating to OpenIB and
> eventually bombs during the checks reporting that OpenIB is not found
> (even though it really is there). After looking through the
> config.log I find an error about not being able to find
> sysfs/libsysfs.h.
>
> after installing sysfsutils-devel (fedora core) the compile proceedes
> w/o a hitch.
>
> Having this be an explicit test (at the top of the openib section?)
> would be wonderful :)
>
> Thanks,
> Josh
>
> grep -r "sysfs/libsysfs.h" *
> ompi/mca/btl/openib/btl_openib_component.c:#include <sysfs/libsysfs.h>
> ompi/dynamic-mca/btl/openib/btl_openib_component.c:#include
> <sysfs/libsysfs.h>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>