Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Brian W. Barrett (brbarret_at_[hidden])
Date: 2006-05-26 12:16:03


On Fri, 26 May 2006, Jeff Squyres (jsquyres) wrote:

> You can see this by slightly modifying your test command -- run "env"
> instead of "hostname". You'll see that the environment variable
> OMPI_MCA_mpi_yield_when_idle is set to the value that you passed in on
> the mpirun command line, regardless of a) whether you're oversubscribing
> or not, and b) whatever is passed in through the orted.

While Jeff is correct that the parameter informing the MPI process that it
should idle when it's not busy is correctly set, it turns out that we are
ignoring this parameter inside the MPI process. I'm looking into this and
hope to have a fix this afternoon.

Brian