Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Brian Barrett (brbarret_at_[hidden])
Date: 2006-05-08 09:06:32


On May 8, 2006, at 1:54 PM, Ralf Wildenhues wrote:

> Hi Brian, Dries,
>
> * Brian Barrett wrote on Mon, May 08, 2006 at 01:43:38PM CEST:
>>
>> However, we really *should* abort configure and warn the user if --
>> enable-io-romio is given and ROMIO fails to configure. I will fix
>> this with the LDFLAGS fix. I'll let you know when the fixes become
>> available
>
> While you're looking at config/ompi_config_subdir* anyway, you may be
> interested to know that it mistreats some arguments with special
> characters in it. That may not be so important to OpenMPI, but when
> passing the same config.cache file down to the sub-configure (which
> OpenMPI does not do), then it can be:
> http://lists.gnu.org/archive/html/bug-autoconf/2006-04/msg00087.html
> http://lists.gnu.org/archive/html/autoconf-patches/2006-04/
> msg00357.html
>
> It may even be that this comment from configure.ac:
> # AC_CONFIG_SUBDIRS appears to be broken for non-gcc compilers (i.e.,
> # passing precious variables down to the sub-configure).
>
> hints at the very problem linked to above, but frankly, I don't know
> that. Again, if that was a different issue with AC_CONFIG_SUBDIRS,
> it'd be great to hear about it.

I don't remember what the issue was -- Jeff, do you remember?

I think we disabled config.cache for other reasons -- namely that we
(Open MPI) internally add compiler flags, so that made config.cache
really difficult to do right.

Brian