Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Greg Watson (gwatson_at_[hidden])
Date: 2006-03-17 10:17:27


I'm building OMPI 1.0.2a9 on a bproc machine (Yellow Dog Linux 4.0/
ppc). It just has an ethernet interface, no fancy network.

I've tried configuring as follows:

./configure --enable-static --disable-shared --without-threads --with-
devel-headers

and

./configure --enable-static --disable-shared --without-threads --
without-mpi-threads --with-devel-headers

In both cases, I'm still seeing the thread library linked in the
final executable:

$ mpicc -o testmpi testmpi.c
$ ldd testmpi
         libutil.so.1 => /lib/libutil.so.1 (0x0f590000)
         libnsl.so.1 => /lib/libnsl.so.1 (0x0e850000)
         libdl.so.2 => /lib/libdl.so.2 (0x0fdc0000)
         libbproc.so.4 => /usr/lib/libbproc.so.4 (0x0fe50000)
         libpthread.so.0 => /lib/tls/libpthread.so.0 (0x0fc40000)
         librt.so.1 => /lib/tls/librt.so.1 (0x0f660000)
         libm.so.6 => /lib/tls/libm.so.6 (0x30013000)
         libc.so.6 => /lib/tls/libc.so.6 (0x0fe70000)
         /lib/ld.so.1 => /lib/ld.so.1 (0x0ffd0000)
$

Checking ompi_config.h shows:

#define HAVE_PTHREAD_H 1
#define OMPI_ENABLE_MPI_THREADS 0
#define OMPI_ENABLE_PROGRESS_THREADS 0
#define OMPI_HAVE_POSIX_THREADS 0
#define OMPI_HAVE_SOLARIS_THREADS 0
#define OMPI_THREADS_HAVE_DIFFERENT_PIDS 0

If anyone can tell me what I'm doing wrong, it would be appreciated.
I need to get this working for a demo on Monday.

Thanks,

Greg