Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Ralf Wildenhues (Ralf.Wildenhues_at_[hidden])
Date: 2005-10-25 02:48:33


Hi Jeff, Troy,

* Jeff Squyres wrote on Mon, Oct 24, 2005 at 06:43:38PM CEST:
> Troy Benjegerdes wrote:
>
> > Another note.. I think I may have had some problems because I built with
> > 'make -j16'.. has anyone else tried parallel make builds?
>
> I am jumping into this thread late -- but FWIW:

Me too. :)

> 1. Yes, we build VPATH (with both relative and absolute flavors) every
> night. So the build works fine. If gdb can't find stuff, that's a
> different issue -- I don't know if the linker stores VPATH information
> properly for debuggers to find files properly or not (this is part of
> the Automake magic that we rely on).

Finding sources is usually not an autotools or make issue, but as far as
I know, an issue of how sophisticated the compiler is with creating
debugging information (and whether the binary format allows to store
them). In doubt, gdb's `directory' command may be used to specify
additional directories to have it search for source files in.

> 2. Yes, we do parallel builds all the time (and every night).

Now that Troy mentions it: I vaguely remember bug reports about
parallel builds failing with some versions of GNU make and autotools,
but have never been able to reproduce any of them (except for some that
turned out to have different cause).

If this error persists, and you are willing to help, I would like to
know: exact versions of make, all autotools, exact source tree (svn
version of OpenMPI), build system details (OS, kernel version, number of
processors) and a complete log of configure and make output. Thanks!

Cheers,
Ralf