Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Ralf Wildenhues (Ralf.Wildenhues_at_[hidden])
Date: 2005-10-25 01:57:28


Hi Troy,

* Troy Benjegerdes wrote on Tue, Oct 25, 2005 at 03:30:46AM CEST:
> On Mon, Oct 24, 2005 at 07:30:54PM -0500, Brian Barrett wrote:
> > On Oct 24, 2005, at 6:56 PM, Troy Benjegerdes wrote:
> >
> > >> | configure: /bin/sh './configure' *failed* for opal/libltdl
> > >>
> > >> Troy, could you show opal/libltdl/config.log, or, if that does not
> > >> reveal anything suspicious, the corresponding part of toplevel
> > >> config.log (above message should be recorded there)? Thanks.
> > >>
> > >
> > > ARGGGG.. libltdl3-dev seemed to not be installed.
> > >
> > > Any way to make a check for this more explicit in autogen.sh?
> >
> > We don't use the system-installed libltdl, and always build our own.
> > It looks like you should only need the libtool package, which we
> > should check for already in autogen.sh. Was there any useful error
> > message along the way?
>
> I recall some error about libtool/libltdl, but it looked like it
> succeeded.

If you don't have the exact output any more: could you please rerun
autogen.sh and post it?

> Do you have a debian system you can remove the libltdl3 and libltdl3-dev
> packages?

Yes, I could try that tonight (my timezone), but..

> It seems like there's some strange depenency on this.

I don't either think this is the cause of the error. What is the
libtoolize version autogen.sh picks up?

Cheers,
Ralf