Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Tim S. Woodall (twoodall_at_[hidden])
Date: 2005-09-21 08:24:42


Thats correct. Not sure why TCP would have been used - unless IB
interfaces weren't up..

Brian Barrett wrote:
> Tim -
>
> Just to make sure I"m not losing it - if any of the "high speed"
> networks is found between peers, tcp shouldn't be used between that
> pair, right? I was pretty sure that's what the priority code did
> now, but wanted to make sure I wasn't losing it ;).
>
> Brian
>
> Begin forwarded message:
>
>
>>From: "Tim S. Woodall" <twoodall_at_[hidden]>
>>Date: September 20, 2005 7:51:42 PM GMT+02:00
>>To: Open MPI Users <users_at_[hidden]>
>>Subject: Re: [O-MPI users] HOWTO turn of "multi-rail" support at
>>runtime?
>>Reply-To: Open MPI Users <users_at_[hidden]>
>>
>>
>>Daryl,
>>
>>Try setting:
>>
>>-mca btl_base_include self,mvapi
>>
>>To specify that only lookback (self) and mvapi btls should be used.
>>
>>Can you forward me the config.log from your build?
>>
>>Thanks,
>>Tim
>>
>>Daryl W. Grunau wrote:
>>
>>
>>>Hi, I've got a dual-homed IB + GigE connected cluster for which
>>>I've built
>>>a very recent drop of OpenMPI (w/ mvapi support). I'm having
>>>difficulty
>>>making OMPI solely use native verbs as it's communication between
>>>nodes.
>>>I've tried all incantations of the following mca parameters to no
>>>avail:
>>>
>>> --mca btl_tcp_if_exclude "lo,eth0,eth1,ib0,ib1"
>>> --mca ptl_tcp_if_include "lo,eth0,eth1,ib0,ib1"
>>>
>>>Note I'm putting ib in the list because I really don't wish to use
>>>IP/IB;
>>>OMPI should be able to communicate at the native verbs level,
>>>right? If I
>>>leave ib0/1 unconfigured on my host, OMPI uses eth0 for its
>>>communication.
>>>If I bring up ib0, OMPI uses both eth0 and ib0! Is there any way
>>>I can
>>>specify for it to use none of these TCP interfaces? TIA!
>>>
>>>Daryl
>>>
>>>P.s. I can send output of ompi_info if that is helpful.
>>>_______________________________________________
>>>users mailing list
>>>users_at_[hidden]
>>>http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>>
>>
>>_______________________________________________
>>users mailing list
>>users_at_[hidden]
>>http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>