Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Nathan DeBardeleben (ndebard_at_[hidden])
Date: 2005-09-13 14:50:59


Compiling I get:

> gcc -DHAVE_CONFIG_H -I. -I. -I../../../../include
> -I../../../../include -I../../../../include -I../../../..
> -I../../../.. -I../../../../include -I../../../../opal
> -I../../../../orte -I../../../../ompi -g -Wall -Wundef -Wno-long-long
> -Wsign-compare -Wmissing-prototypes -Wstrict-prototypes -Wcomment
> -pedantic -Werror-implicit-function-declaration -fno-strict-aliasing
> -MT btl_gm.lo -MD -MP -MF .deps/btl_gm.Tpo -c btl_gm.c -fPIC -DPIC -o
> .libs/btl_gm.o
> btl_gm.c: In function `mca_btl_gm_prepare_src':
> btl_gm.c:237: error: `gm_btl' undeclared (first use in this function)
> btl_gm.c:237: error: (Each undeclared identifier is reported only once
> btl_gm.c:237: error: for each function it appears in.)
> btl_gm.c: In function `mca_btl_gm_prepare_dst':
> btl_gm.c:398: warning: ISO C89 forbids mixed declarations and code
> btl_gm.c:404: error: structure has no member named `mpoo_retain'
> btl_gm.c:381: warning: unused variable `gm_btl'
> make[4]: *** [btl_gm.lo] Error 1
> make[4]: Leaving directory `/home/ndebard/ompi/ompi/mca/btl/gm'
> make[3]: *** [all-recursive] Error 1
> make[3]: Leaving directory `/home/ndebard/ompi/ompi/dynamic-mca/btl'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory `/home/ndebard/ompi/ompi/dynamic-mca'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/ndebard/ompi/ompi'
> make: *** [all-recursive] Error 1
> [sparkplug]~/ompi >

I've configured using the option I thought to disable this:

> --enable-mca-no-build=ptl-gm

I even tried --enable-mca-no-build=btl-gm.
No luck.

-- 
-- Nathan
Correspondence
---------------------------------------------------------------------
Nathan DeBardeleben, Ph.D.
Los Alamos National Laboratory
Parallel Tools Team
High Performance Computing Environments
phone: 505-667-3428
email: ndebard_at_[hidden]
---------------------------------------------------------------------