Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Peter Kjellström (cap_at_[hidden])
Date: 2005-09-02 03:13:12


On Friday 26 August 2005 19.37, Ralf Wildenhues wrote:
> * Peter Kjellström wrote on Fri, Aug 26, 2005 at 06:24:43PM CEST:
> > On Friday 26 August 2005 18.04, Ralf Wildenhues wrote:
> > > Libtool version previous to 1.5.16 had a bug in the macro to detect
> > > this; it was often wrong before.
> >
> > my libtool is indeed rather ancient compared to 1.5.16, I knew ompi
> > needed a recent one but had assumed that an updated centos-4.1 (rhel4u1)
> > would be enough... (I have 1.5.6)
> >
> > Either way, I have managed to build ompi before so I looked deeper and
> > found out that the intel compilers had been updated under my feet (-027
> > to -029). Switching back made configure run just fine...
>
> OK. But see, I'd still like to know whether libtool-1.5.18 copes with
> your newer icc. I can't fix it (given there is something to fix) unless
> I know about the failure.

Just to end this thread nicely, I was able to build svn7132 with icc-8.1e-029
just fine (now with recommended libtool&co). I think we fixed a bug in our
compiler installation too so I'm not sure if it was the libtool upgrade or
not but either way it works now :-)

/Peter

>
> Cheers,
> Ralf



  • application/pgp-signature attachment: stored