Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2005-09-01 09:24:13


I think Brian sent the workaround the other day (I don't know if he got
to commit a proper fix or not -- he left for travel shortly after
that), but I also thought that George fixed the issue in his
configure.m4...? (could be wrong; I don't build GM regularly)

-----
        From: brbarret_at_[hidden]
        Subject: [O-MPI devel] WRAPPER_EXTRA_LIBS build issues
        Date: August 30, 2005 1:06:14 PM EDT
        To: devel_at_[hidden]
        Reply-To: devel_at_[hidden]

Hi all -

for those having issues with WRAPPER_EXTRA_LIBS/LDFLAGS constants
showing up in the output of mpicc, a quick workaround is to disable
the GM PTL during configure. This can be accomplished by adding the
configure flag:

    --enable-mca-no-build=ptl-gm

to your configure line, then rebuilding. I hope to have a proper
solution later today.

Brian
-----

On Sep 1, 2005, at 10:00 AM, Tim S. Woodall wrote:

> What is the status of the gm configure issue:
>
> mpicc -O -DMPI ./src/netpipe.c ./src/mpi.c -o NPmpi -I./src
> gcc: WRAPPER_ALWAYS_EXTRA_LIBS: No such file or directory
> gcc: WRAPPER_ALWAYS_EXTRA_LIBS: No such file or directory
>
>
> Is there a simple work-around, or should I just compile/link
> the app w/out mpicc?
>
> Tim
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>

-- 
{+} Jeff Squyres
{+} The Open MPI Project
{+} http://www.open-mpi.org/