Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Ralf Wildenhues (Ralf.Wildenhues_at_[hidden])
Date: 2005-08-31 23:37:09


* George Bosilca wrote on Thu, Sep 01, 2005 at 06:27:27AM CEST:
> I trace this one as far as I could. And the results are mostly unexpected.
> On some of the clusters it compiles without any problems and on some
> others it doesn't. The difference is ... if there is an ltdl.h installed
> in the system directories. I don't think that's the expected behavior for
> the compilation, if we have our own ltdl.h file why should we use the
> system wide one ...

This is usually up to the user's choice at some point (I don't know
about OpenMPI with that respect).

> For some component it work as expected because on the revision 7106 the
> -I$(top_srcdir)/opal/libltdl has been added to the AM_CPPFLAGS in the
> Makefile.am. As most of our code use components there is a dependency
> between nearly every file in the ompi source code and the ldtl.h file.
> Having to modify all the Makefile.am is a herculean task ...

Ah, ok, I was blind then, in thinking only the parts that compiled over
here used ltdl.h. There are a couple of ways to add include paths to
many Makefile.am's: You could leverage config/Makefile.options, and set
a default value for AM_CPPFLAGS (surely you have to change the
Makefile.am's once to only add to AM_CPPFLAGS afterwards; or, maybe
better, to add some other variable CPPFLAGS_LTDL set in
Makefile.options).

But surely, once the work has to be done. I suggested that change
because before, the code would've broken with Libtool-2.x anyway.

Cheers,
Ralf