Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: James W. Barker (jbarker_at_[hidden])
Date: 2005-08-17 16:35:42


All,

I'm having trouble with auotgen.sh. Autogen.sh errors saying I need to
install Autoconf 2.58 but I am at version 2.59; any thoughts?

Jim Barker

Open MPI MCA component configure generator finished
*** Running GNU tools
[Running] aclocal
aclocal:configure.ac:108: warning: macro `AM_ENABLE_SHARED' not found in
library
aclocal:configure.ac:109: warning: macro `AM_DISABLE_STATIC' not found in
library
aclocal:configure.ac:383: warning: macro `AM_PROG_LIBTOOL' not found in library
[Running] autoheader
[Running] autoconf
configure.ac:110: error: possibly undefined macro: AM_ENABLE_SHARED
       If this token and others are legitimate, please use m4_pattern_allow.
       See the Autoconf documentation.
configure.ac:111: error: possibly undefined macro: AM_DISABLE_STATIC
configure.ac:395: error: possibly undefined macro: AM_PROG_LIBTOOL

-------------------------------------------------------------------------
It seems that the execution of "autoconf" has failed. See above for
the specific error message that caused it to abort.

This *MAY* be caused by an older version of one of the required
packages. Please make sure you are using at least the following
versions:

GNU Autoconf 2.58
GNU Automake 1.7
GNU Libtool 1.5
-------------------------------------------------------------------------

ffe1.lanl.gov> autoconf -V
autoconf (GNU Autoconf) 2.59
Written by David J. MacKenzie and Akim Demaille.

Copyright (C) 2003 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

James W. Barker Ph.D.
CCS-1, Resilient Technologies Team
505-665-9558