Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Brian Barrett (brbarret_at_[hidden])
Date: 2005-08-12 15:17:49


On Aug 12, 2005, at 3:13 PM, Nathan DeBardeleben wrote:

> We've got a 64bit Linux (SUSE) box here. For a variety of reasons
> (Java, JNI, linking in with OMPI libraries, etc which I won't get
> into)
> I need to compile OMPI 32 bit (or get 64bit versions of a lot of other
> libraries).
> I get various compile errors when I try different things, but first
> let
> me explain the system we have:

<snip>

> This goes on and on and on actually. And the 'is incompatible with
> i386:x86-64 output' looks to be repeated for every line before this
> error which actually caused the Make to bomb.
>
> Any suggestions at all? Surely someone must have tried to force
> OMPI to
> build in 32bit mode on a 64bit machine.

I don't think anyone has tried to build 32 bit on an Opteron, which
is the cause of the problems...

I think I know how to fix this, but won't happen until later in the
weekend. I can't think of a good workaround until then. Well, one
possibility is to set the target like you were doing and disable
ROMIO. Actually, you'll also need to disable Fortran 77. So
something like:

   ./configure [usual options] --build=i586-suse-linux --disable-io-
romio --disable-f77

might just do the trick.

Brian

-- 
   Brian Barrett
   Open MPI developer
   http://www.open-mpi.org/