Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Ralph H. Castain (rhc_at_[hidden])
Date: 2005-08-08 08:44:48


Very interesting - it built fine for me (building static). However,
the ns_base_nds.c file is "stale", so I just committed a "delete" of
that file. It shouldn't have been building anyway as it isn't in the
Makefile. My guess, therefore, is that you are building dynamically
and are encountering the old "stale library" problem.

My commit won't fix that situation, unfortunately. If you are
building dynamically, you need to remove your libraries (do an rm -rf
of the directory root your provided as --prefix) to fix the problem.

Ralph

At 07:29 AM 8/8/2005, you wrote:
>Hello,
>
>I've got this compile error with the latest svn code.
>
>mca/ns/base/.libs/libmca_ns_base.a(ns_base_local_fns.o)(.text+0xfa7): In
>function `orte_ns_base_get_peers':
>/home/glebn/OpenMPI_latest/ompi/orte/mca/ns/base/ns_base_local_fns.c:609:
>multiple definition of `orte_ns_base_get_peers'
>mca/ns/base/.libs/libmca_ns_base.a(ns_base_nds.o)(.text+0x116):/home/glebn/OpenMPI_latest/ompi/orte/mca/ns/base/ns_base_nds.c:31:
>first defined here
>collect2: ld returned 1 exit status
>make[2]: *** [liborte.la] Error 1
>make[2]: Leaving directory `/export/home/glebn/OpenMPI_latest/ompi/orte'
>make[1]: *** [all-recursive] Error 1
>make[1]: Leaving directory `/export/home/glebn/OpenMPI_latest/ompi/orte'
>make: *** [all-recursive] Error 1
>
>--
> Gleb.
>_______________________________________________
>devel mailing list
>devel_at_[hidden]
>http://www.open-mpi.org/mailman/listinfo.cgi/devel