Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Sridhar Chirravuri (sridhar_at_[hidden])
Date: 2005-08-08 05:19:56


Hi,

I was trying to build the latest code but as I mentioned in one of my
previous mails, build is getting into a loop.

[root_at_micrompi-1 ompi]# make all | tee mymake.log
make: Warning: File `Makefile.am' has modification time 3.6e+04 s in the
future
cd . && /bin/sh /ompi/config/missing --run aclocal-1.9
/usr/share/aclocal/libgcrypt.m4:23: warning: underquoted definition of
AM_PATH_LIBGCRYPT
  run info '(automake)Extending aclocal'
  or see
http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/share/aclocal/ao.m4:9: warning: underquoted definition of
XIPH_PATH_AO
 cd . && /bin/sh /ompi/config/missing --run automake-1.9 --foreign
cd . && /bin/sh /ompi/config/missing --run autoconf
/bin/sh ./config.status --recheck
 /bin/sh ./config.status
Making all in config
make[1]: make[1]: Entering directory `/ompi/config'
Warning: File `Makefile.am' has modification time 3.6e+04 s in the
future
cd .. && make am--refresh
make[2]: Entering directory `/ompi'
make[2]: Warning: File `Makefile.am' has modification time 3.6e+04 s in
the future
cd . && /bin/sh /ompi/config/missing --run aclocal-1.9
/usr/share/aclocal/libgcrypt.m4:23: warning: underquoted definition of
AM_PATH_LIBGCRYPT
  run info '(automake)Extending aclocal'
  or see
http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/share/aclocal/ao.m4:9: warning: underquoted definition of
XIPH_PATH_AO
 cd . && /bin/sh /ompi/config/missing --run automake-1.9 --foreign
cd . && /bin/sh /ompi/config/missing --run autoconf
/bin/sh ./config.status --recheck
 /bin/sh ./config.status
make[2]: warning: Clock skew detected. Your build may be incomplete.
make[2]: Leaving directory `/ompi'
make[2]: Entering directory `/ompi'
make[2]: Warning: File `Makefile.am' has modification time 3.6e+04 s in
the future
cd . && /bin/sh /ompi/config/missing --run aclocal-1.9
/usr/share/aclocal/libgcrypt.m4:23: warning: underquoted definition of
AM_PATH_LIBGCRYPT
  run info '(automake)Extending aclocal'
  or see
http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/share/aclocal/ao.m4:9: warning: underquoted definition of
XIPH_PATH_AO
 cd . && /bin/sh /ompi/config/missing --run automake-1.9 --foreign
cd . && /bin/sh /ompi/config/missing --run autoconf
/bin/sh ./config.status --recheck
 /bin/sh ./config.status
make[2]: warning: Clock skew detected. Your build may be incomplete.
make[2]: Leaving directory `/ompi'
cd .. && make am--refresh
make[2]: make[2]: Entering directory `/ompi'
Warning: File `Makefile.am' has modification time 3.6e+04 s in the
future
cd . && /bin/sh /ompi/config/missing --run aclocal-1.9
/usr/share/aclocal/libgcrypt.m4:23: warning: underquoted definition of
AM_PATH_LIBGCRYPT
  run info '(automake)Extending aclocal'
  or see
http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/share/aclocal/ao.m4:9: warning: underquoted definition of
XIPH_PATH_AO
 cd . && /bin/sh /ompi/config/missing --run automake-1.9 --foreign

make[2]: *** [Makefile.in] Interrupt
make[1]: *** [../configure] Interrupt
make: *** [all-recursive] Interrupt

The config.status -recheck is being issued from Makefile. I have moved
config.status to config.status.old and did touch config.status but still
"make all" is going in loop.

Is anyone tried building the latest code drop of OpenMPI? Or Is anyone
has seen this type of behavior?

Please let me know.

Thanks
-Sridhar

                -----Original Message-----
                From: Sridhar Chirravuri
                Sent: Monday, August 08, 2005 2:28 PM
                To: 'Open MPI Developers'
                Cc: Sridhar Chirravuri
                Subject: RE: [O-MPI devel] Fwd: Regarding MVAPI
Component in Open MPI

                Hi,

                I have got the latest code drop and this time I didn't
give -r option to svn co. The last line that it showed me is given
below.

                Checked out revision 6760.

                I am trying to install/configure/build OpenMPI on RHEL3
update 4 machine. For this release, we don't have lmpga and lmtl_common
libraries. We are not using separate VAPI libraries. We only use lvapi
and lmosal. We do have lmpga and lmtl_common libs but with the older
release.

                In the file README of latest check out, I could see the
following lin

                - Support for Quadrics and Infiniband (both mVAPI and
OpenIB) is
                  missing (see the current code base).

                What does it mean? Does OpenMPI has support for
Infiniband (mVAPI)? I am not getting why btl mVAPI component is not
being built (in my previous mail with ompi_info output). Could you
please let me know whether OpenMPI has got support for Infiniband
(mVAPI)? If yes, what sort of configuration options that I need to give?
Or Do I have to modify anything in the respective directories? Please
let me know.

                Thanks
                -Sridhar

                -----Original Message-----
                From: devel-bounces_at_[hidden]
[mailto:devel-bounces_at_[hidden]] On Behalf Of Jeff Squyres
                Sent: Friday, August 05, 2005 6:15 PM
                To: Open MPI Developers
                Subject: Re: [O-MPI devel] Fwd: Regarding MVAPI
Component in Open MPI

                On Aug 5, 2005, at 8:02 AM, Sridhar Chirravuri
((schirrav)) wrote:

> Here is the output of ompi_info
>
> [root_at_micrompi-1 ompi]# ompi_info
> Open MPI: 1.0a1r6612M
> Open MPI SVN revision: r6612M
> [snipped]
> The OpenMPI version that I am using r6612 (I could see
from the output
> ompi_info command). There is NO btl frame where as
mpool was built.
>
> In the configure options, giving
--with-btl-mvapi=/opt/topspin would
> sufficient as it has got include and lib64
directories. Therefore it
> will pick up the necessary things. Also, I have set
the following
> flags

                Good.

> export CFLAGS="-I/optl/topspin/include
-I/opt/topspin/include/vapi"
> export LDFLAGS="-lmosal -lvapi -L/opt/topspin/lib64"
> export btl_mvapi_LDFLAGS=$LDFLAGS
> export btl_mvapi_LIBS=$LDFLAGS

                You shouldn't need these -- our configure script should
figure all that
                out with just the --with-btl-mvapi switch. Let us know
if it doesn't
                (an explicit goal of our configure script is to handle
all this kind of
                complexity and do all the Right Things with a single
--with switch).

> I will configure and build the latest code. To get the
latest code, I
> have run the following command. Please let me know if
I am not
> correct.
>
> svn co -r6613 http://svn.open-mpi.org/svn/ompi/trunk
ompi

                No -- do not specify the -r switch. That asks for a
specific
                repository r number, and 6613 only 1 commit beyond your
last version.
                The current r number at the HEAD is 6746, for example --
6613 was
                committed around 9am on July 27th. Specifically, the r
number
                represents a unique state of the *entire* repository.
So every commit
                increments the r number (more Subversion documentation
is available
                here: http://svnbook.red-bean.com/).

                I believe that in 6612 and 6613, we still had many of
the 3rd
                generation BTL stuff .ompi_ignore'd out, so they would
not have built
                (many were removed at 6616, but even more were removed
as late as
                6658).

                Note that the "M" in your version number means that you
have locally
                modified the tree -- so you started with r6612, but then
made local
                modifications (the configure script queries Subversion
to see what
                version your tree it; Subversion detects these kinds of
things).

                If you "svn co http://svn.open-mpi.org/svn/ompi/trunk
ompi" (i.e., do
                not specify -r), it'll just get the latest number.

                Alternatively, if you have a checkout already, you can
just run "svn
                up" within that tree and it will update to the latest
(quite analogous
                to "cvs up").

> Configured as..
>
> ./configure --prefix=/openmpi
--with-btl-mvapi=/opt/topspin/

                When you get a subversion checkout, you need to first
run autogen.sh.
                See the HACKING document for details on this (you don't
need to run
                autogen.sh in tarballs) and the README document for
common building /
                running. Both of these are in the top-level directory
of the SVN
                checkout (update to the latest to get the most
up-to-date README
                information).

> When I gave make all, it is configuring again and
again, I mean it is
> going in a loop. In my machine, I do not need libmpga
and
> libmtl_common, hence I removed -lmpga and -lmtl_common
entries from
> config/ompi_check_mvapi.m4 file and then ran
autogen.sh.

                If you modify a .m4 file, you need to run autogen.sh
again.

                autogen.sh is simply a wrapper around all the right GNU
Auto tool
                commands (autoconf, autoheader, libtool, automake, etc.)
to setup all
                the build scripts properly. However, automake also
inserts
                dependencies in makefiles such that if any of the
dependent m4 files
                change (for example), it should re-run the necessary
commands. In
                theory, that is supposed to work, but we've never really
exercised that
                -- we just re-run autogen.sh.

                But could you clarify -- why do you not need libmpga or
libmtl_common?
                Are these libraries from a different mVAPI
implementation? I would
                like to have our configure script do the Right Things
regardless of
                which mVAPI implementation is being used -- if we need
to add a little
                more logic to make this correct, then so be it.

> I don't have any clue why the configuration is going
in loop even
> while building. I could see that config.status
--recheck is being
> issued from Makefile and I feel this might the reason
for configure to
> run in loop.

                Running autogen.sh should do the Right Things for you.

                --
                {+} Jeff Squyres
                {+} The Open MPI Project
                {+} http://www.open-mpi.org/

                _______________________________________________
                devel mailing list
                devel_at_[hidden]
                http://www.open-mpi.org/mailman/listinfo.cgi/devel