Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2005-08-04 05:43:01


> From: "Sridhar Chirravuri \(schirrav\)" <schirrav_at_[hidden]>
> Date: August 4, 2005 2:07:04 AM EDT
> Cc: "Sridhar Chirravuri \(schirrav\)" <schirrav_at_[hidden]>
> Subject: Regarding MVAPI Component in OpenMPI
>
> All,
>  
> I got OpenMPI tar ball and could configure and build on AMD x86_64
> arch.
>  
> In our case, we need to enable MVAPI and disable OpenIB. For this, I
> have moved .ompi_ignore file from mvapi directory to openib directory.
> I could see that OpenIB was disabled as the entire openib tree was
> skipped by the autogen.sh script.
>  
> While running Pallas accross the nodes, I could see that data is
> passing over Gigbit ethernet and NOT over Infiniband.  Does anyone has
> idea about why data is going through Gig and NOT over infiniband? Do I
> have to set any configuration options? Do I have to give any run-time
> options? I have tried with mpirun -mca btl mvapi but of no use.
>  
> I could make out that TCP component is being used and in order to
> disable tcp, I have copied .ompi_ignore in to directories
> /ompi/orte/mca/oob/tcp and /ompi/ompi/mca/ptl/tcp. But this time
> program fails with segmentation fault error.
>  
> These are the configure options that I have given while configuring
> OpenMPI.
>  
> ./configure --prefix=/openmpi --with-btl-mvapi=/usr/local/topspin/
> --with-btl-mvapi-libdir=/usr/local/topspin --with-mvapi
>  
> Please help me in resolving this.
>  
> Thanks
> -Sridhar